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Overview

These instructions explain how to use the SCC configuration software to set up an AVPC sign.

Revision History

Related documentation

SCC configuration software

• avpccfg.exe — the main program used to set up an AVPC sign.

• SCC Emulator.exe — used to display templates on a sign.

Revision Date Notes

9713-4011 January 24. 2005 First release

9713-4011A March 25, 2005

9713-4011A February 13, 2006 Information added regarding 801 SCC objects to Software description

Part number Title

9713-4012 AVPC ANDON Sign Installation Manual
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Main sign setup tasks

Using the SCC configuration software, do the following for each AVPC sign:

NOTE: Access the SCC configuration software stored on a sign’s hard disk by either:
(1) attaching a keyboard and monitor directly to the sign’s embedded PC or
(2) connecting the sign to a TCP/IP network and using software like RealVNC (http://
www.realvnc.com) or Windows NetMeeting (http://www.microsoft.com/windows/
netmeeting) to remotely access a sign’s embedded PC.

• Set the software to match the size of your AVPC sign.

• Set the clock format for the SCC emulator software (12 or 24 hour).

• Set the TCP/IP Port number for the SCC emulator software (default = 3001).

• Create a main template (default = 00) and an optional Failover template to control what is 
displayed on the sign.

• Set up the sign’s TuneBlaster sound card.
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Software description

When the SCC AVPC Config Software (avpccfg.exe) is started, the following screen appears:

Startup screen for avpccfg.exe software

Item Name Description

A New Creates a new template.

B Open Opens an existing template.

C Save Saves the current template.

D Transfer Not used.

E Delete Deletes the selected protocol section of the current template.

F Properties Allows editing of the properties for the selected protocol section.

G Resize Determines the length (columns) and height (rows) of the entire sign and also lets you choose a 
zoom factor for displaying the sign and its objects during configuration.

H About Displays program information, version number, and copyright.

I 801* SCC object

Creates an 801 object on the current template for an SCC counter object (1 line):

A

I

B C E F G H

J
K

D

Templates are created in this area. This area represents a sign’s 
display area — in this case 320 x 96 pixels (length x height).

To change this area to match a sign’s display, click View > Resize.L
M
N

801 Device Set Properties:
• Position — selectable Left, Top, Width and 

Height.
• Address — selectable Group Address and Unit 

Address.
• Layout — default template information will be 

shown in gray area.

Edit Button — allows user to edit template.
Color Link Button — allows user to define the 
color of the object based on:

• a PLC Tag value
• the value of another 801 object
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J 952* SCC object Creates a 952 (or 954) object on the current template for an SCC alphanumeric text display without 
bin support.
• 1 line supported for this model type
• Default height: 4"
• Default width: 20 characters
• Default color: Red
• Default text: none
• Options: Flashing (default = off), 2 speeds

K 954* SCC object

L 974* SCC object

Creates a 974 object on the current template for an SCC alphanumeric text display with bin 
selection option:
• Number of lines based on the height of the display and the height of each row.
• Default height: 4"
• Default width: 20 characters
• Default color: Red
• Default text: none
• Options: Flashing (default = off), 2 speeds
• Justification: Left, Center
• Block option: Allows a cell to change colors (blank box)

M 955* SCC object Creates a 955 object on the current template.

N PLC object

Creates a PLC object:

* SCC objects can have a maximum of 99 object types on one display. Objects such as 952 and 974 will count the complete object
as a whole regardless of the number of lines selected. For example, a 952 with 1 line counts as one object and a 974 with 6 lines
also counts as one object.

Startup screen for avpccfg.exe software

Possible PLC object Attributes:
• Lookup — uses the “Name” Tag Name 

value to display the text from the Lookup 
table. Go to Tools > PLC Lookup Editor for a 
list of possible values.

• Static — displays the actual value in the 
“Name” Tag Name. Set the Color, Flash, and 
Background here.

• Dynamic — displays the actual value in the 
“Name” Tag Name. Uses the “Source” Tag 
Name value to get the Color and Flash from 
the Attribute table. Go to Tools > PLC 
Attribute Editor. 

• Message — uses the “Name” Tag Name 
value to display the text from the Message 
table. Go to Tools > PLC Message Editor for 
a list of possible messages.

Ford.FordPCB.10 
(KEPServer name)

Ford = Device
FordPCB = Tag Group

10 = Tag Name
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Basic software setup

Set display size

1. Click View > Resize. Make sure that the columns and rows in this window are the same as your 
sign. Then click OK:

Set clock format

2. Click Tools > Clock Setup. Select how time will appear on the sign. Then click OK:

Set TCP/IP Port number

3. Click Tools > Display Setup. Set the TCP/IP Port number (default = 3001):

To trigger the Lamp Test 
from a PLC, you must fill in 
the KEPServer Tag Name.

Note: The IP Address and 
Serial Number fields are 
not used.
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Select main templates and a Failover (optional) template

4. Click Display Setup > Templates. Assign template files to a slot by selecting the slot and clicking 
Browse. (The template in Slot 00 is the template that will load at startup.) Also, select an optional 
Failover template. Then click OK:

Set up the sign’s TuneBlaster sound card

5. Click Tools > TuneBlaster Setup. Set up the TuneBlaster. Then click OK:

Main templates — used to control what 
information appears on a sign. “Unassigned” 
after a number means that no template has 
been assigned to this slot.

Failover template (optional) — a template 
used to display information when a sign has 
a communication failure.
To enable the Failover template, check one or 
more Transaction Counter.
A communication failure occurs when one or 
more of the selected counters receives no 
data for the amount of time specified in 
Timeouts(s).

When any one of the above selected 
counters stops receiving data for the 
time specified, then a communication 
failure has occurred.

After a Transaction Counter has timed out, a 
communication failure occurs. In order for the 
communication failure to end, the counter must 
successfully receive data for the time specified here.

To create a template, see “Creating a 
template” on page 12.

Channel 1 can be controlled by a 
KEPServer Tag or an SCC command. 
The Tag value determines which WAV 
file to play.

Channel 2 through 8 are controlled by 
SCC TU1 and TU2 commands.
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6. To set how Channel 1 is controlled, click Tools > Select WAV Files:

Use the dropdown to select 
how Channel 1 is controlled.

To change a WAV file, select a Tune number and click Browse.
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Basic KepServerEx setup

NOTE: Click the Help drop-down menu or click any Help button located in the software for additional 
information.

Add a new tag

1. Click Edit > New Tag. Enter a Name and Address for the Tag. Then click OK.

Test the PLC connection

2. Click Tools > Launch OPC Quick Client. If there is a valid connection to the PLC, the data in the 
Value field will be changing

50 Tags are already configured for you (10-17, 20-27, 30-37, 40-47, 50-57, 60-67, 70-71). 
PLC addresses are octal, so the numbers 8 and 9 do not exist.

Tag Name — used when configuring 
the PLC object in the template.

Tag Address — address (in the PLC) 
of the data.

You will be able to see this data 
changing if there is a valid connection 
to the PLC.
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Creating a template

A template is used to set what information will appear on a sign and where it will appear. To create a 
new template, follow these steps:

1. Click the new icon from the SCC AVPC Config Software startup screen. See “Startup screen for 
avpccfg.exe software” on page 6.

2. Use the SCC objects (801, 952, and so on) to create displays areas:

Each SCC object has 
its own unique Group 
and Unit address (1,1 
and 1,2 and so on).

Double-click an object 
to view its properties.
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3. Use the SCC Emulator.exe program to preview how a template will look on a sign:
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Appendix

Connecting to a sign remotely

To connect to a sign remotely, either VNC Viewer or Windows NetMeeting software must be installed 
on your computer. 

• VNC Viewer is a software application that allows you to see and control the desktop of another 
computer that is running VNC Server software. To obtain this software, go to http://
www.realvnc.com. (Windows 2000 AVPC signs are shipped with VNC Server installed.) In order 
to use the VNC Viewer to control a sign, the sign must have an IP address — and you must know 
what it is.

• Windows NetMeeting is a software application that allows you to see and control the desktop of 
another computer that has NetMeeting Remote Desktop Sharing active. To obtain this software, 
go to http://www.microsoft.com/windows/netmeeting. (Windows 2000 AVPC signs are 
shipped with NetMeeting Remote Desktop Sharing installed.) In order to use Windows 
NetMeeting to control a sign, the sign must have an IP address — and you must know what it is.

Using VNC Viewer

1. Turn off the sign.

2. Attach the sign to a TCP/IP network by connecting to either the
• modular network adapter or
• controller board Ethernet port

NOTE: Your computer must be connected to this same TCP/IP network.

3. Apply power to the sign. Write down the IP address that appears on the sign. An example is 
shown below:

IP Address: 207.12.27.1
Subnet Mask: 255.255.255.0
Gateway: 0.0.0.0
MAC Address: 00-80-66-05-1e-86
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4. Select Start > Programs > RealVNC > VNC Viewer. After VNC Server, type the IP address that was 
displayed on the sign. Then click OK:

5. After Session password, type “admin”. Then click OK.

6. You are now connected to the sign’s desktop. At this point, you can perform any Windows 2000 
activity, such as setting the window area, changing the sign’s IP address, and so on.

This is the sign’s desktop. 
When you work in this 
window, you are working 
on the sign’s hard drive.

This is your desktop. When 
you work in this window, 
you are working on your 
computer’s hard drive.

You can go back and forth 
between desktops — just 
be sure to keep track of 
which desktop window you 
are currently working.
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Using Windows NetMeeting

1. Select Start > Programs > Windows NetMeeting. Then click the button with the phone on it.

2. After To, type the IP Address of the sign. Then click Call. Your computer will wait for a response. 

3. Type the User name and Password in the appropriate fields, then click OK.

Click this button to 
connect to a sign.

Click here to hang up.

Enter the IP address 
here.

Then click Call.

User = Administrator
Password = admin
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4. You are now connected to and have control of the sign.
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Installing software on a Windows 2000 sign’s hard drive

In order to install software on the sign’s hard drive, you must first share your CD-ROM drive with it. 
(Note that there are several ways to get software installed on the sign. This is just one method.)

1. Connect to the sign using VNC Viewer or Windows NetMeeting. See “Connecting to a sign 
remotely” on page 14.

2. Open My Computer on your desktop.

3. Right-click the CD-ROM drive to be shared and select Sharing...

4. Click Share this folder. Then type a Share name. Click the Permissions button.

Double-click My Computer to open it.

First click here.

Then type in a name for the 
shared folder.

Finally, click Permissions.
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5. Select Everyone. Then complete the Permissions as appropriate. When finished, click OK. 

6. On the sign’s desktop, right-click the Start button and select Explore. The sign’s hard drive 
directory appears: 

7. Select My Network Places in the left panel and then double-click Entire Network in the right panel.

8. Double-click the following in the right panel, in the order given: 

• Microsoft Windows Network
• the network on which your computer resides
• your computer (look for your name)
• your computer’s CD-ROM drive (look for the name you gave the shared file in step 3)

9. At this point, you can install software on the sign’s hard drive through your computer’s CD-ROM 
drive.

Select Everyone.

Then select Allow or Deny for each 
Permission.

Click OK.
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Configuring a Windows 2000 sign

You can view and modify your sign’s current settings, as well as see some of the changes before they 
are actually performed. Note that you will need to restart your computer after making any changes.

1. Connect to the sign using VNC Viewer or Windows NetMeeting. See “Connecting to a sign 
remotely” on page 14.

2. Right-click the sign’s desktop and select Properties. The Display Properties window appears:

3. Click the Settings tab and then click the Advanced button. When the advanced properties window 
appears, click the Startup parameters tab and make the appropriate changes:

These are the properties of 
your sign with which you will 
be working.

You can specify turbo card 
information, set the type and size of 
your sign, and indicate whether back-
to-back mounting is used.

NOTE: These items are factory-set and 
changing them may adversely affect 
sign operation.
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4. Click the Capture Windows tab and make the appropriate changes:

5. Click the Color Conversions tab and make the appropriate changes:

6. When changes are complete, click OK, then follow any prompts for restarting your system.

To resize the window, 
position the mouse over 
a corner and, when it 
turns into a double 
arrow, click and drag the 
window inward or 
outward. Note that the 
dimension information 
below changes 
accordingly.

Click here to see a preview of your capture window. 
You can also click and drag this preview window 
inward and outward to change its width and height.

Capture window 
dimension 
information

Capture window preview.
You can click the gray tab and 
drag the window to a different 
area of your screen.

The Insert and Delete 
buttons allow you to 
add and delete capture 
windows. You can have 
up to 99 capture 
windows.

This setting defines how the colors of the 16-
color Windows standard palette (System color) 
are converted into the eight LED colors (LED 
Sign color). For each of the 16 colors, you can 
specify the color to appear on the sign in its 
place. 

Returns the settings to 
their original values.
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Attaching a monitor, keyboard, and mouse directly to a sign

1. Remove power from the sign.

2. Open the sign.

NOTE: For a double-sided sign, just open the Master side.

3. Connect a VGA CRT monitor, computer keyboard and mouse to a sign’s controller board.

4. Apply power to the sign.

Dimming the sign

To dim the sign by 50%, turn off the sign and attach a jumper to J8 on a sign’s controller board.
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